<!DOCTYPE html><html lang="en-AU"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge" /><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Work+Sans:100,200,300,regular,500,600,700,800,900%7CPermanent+Marker:regular%7CBowlby+One:regular&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"> <script>!function(e){var n={};function r(t){if(n[t])return n[t].exports;var o=n[t]={i:t,l:!1,exports:{}};return e[t].call(o.exports,o,o.exports,r),o.l=!0,o.exports}r.m=e,r.c=n,r.d=function(e,n,t){r.o(e,n)||Object.defineProperty(e,n,{enumerable:!0,get:t})},r.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},r.t=function(e,n){if(1&n&&(e=r(e)),8&n)return e;if(4&n&&"object"==typeof e&&e&&e.__esModule)return e;var t=Object.create(null);if(r.r(t),Object.defineProperty(t,"default",{enumerable:!0,value:e}),2&n&&"string"!=typeof e)for(var o in e)r.d(t,o,function(n){return e[n]}.bind(null,o));return t},r.n=function(e){var n=e&&e.__esModule?function(){return e.default}:function(){return e};return r.d(n,"a",n),n},r.o=function(e,n){return Object.prototype.hasOwnProperty.call(e,n)},r.p="",r(r.s=0)}([function(e,n){!function(e){var n=e.ampUrl,r=e.isCustomizePreview,t=e.isAmpDevMode,o=e.noampQueryVarName,i=e.noampQueryVarValue,a=e.disabledStorageKey,u=e.mobileUserAgents,s=e.regexRegex;if("undefined"!=typeof sessionStorage){var c=new RegExp(s);if(u.some((function(e){var n=e.match(c);if(n&&new RegExp(n[1],n[2]).test(navigator.userAgent))return!0;return navigator.userAgent.includes(e)}))){document.addEventListener("DOMContentLoaded",(function(){var e=document.getElementById("amp-mobile-version-switcher");if(e){e.hidden=!1;var n=e.querySelector("a[href]");n&&n.addEventListener("click",(function(){sessionStorage.removeItem(a)}))}}));var f=t&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(!(sessionStorage.getItem(a)||r||f)){var d=new URL(location.href);d.searchParams.has(o)&&i===d.searchParams.get(o)?sessionStorage.setItem(a,"1"):(window.stop(),location.replace(n))}}}}({"ampUrl":"https:\/\/chilloutradio.com\/will-smith\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}]);</script> <script type="text/javascript">var heateorFfcpAjaxUrl = 'https://chilloutradio.com/wp-admin/admin-ajax.php', heateorFfcpWebsiteUrl = 'https://chilloutradio.com';</script> <link media="all" href="https://chilloutradio.com/wp-content/cache/autoptimize/css/autoptimize_d3e6d0936e86fa42143de58f4b994e1f.css" rel="stylesheet" /><title>Will Smith - Primetime Academy Award American Actor</title><meta name="description" content="Everyting about Will Smith actor, including: age, education, religion, movies, Will Smith’s personal life, wife &amp; about his kids." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://chilloutradio.com/will-smith/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Will Smith - Primetime Academy Award American Actor" /><meta property="og:description" content="Everyting about Will Smith actor, including: age, education, religion, movies, Will Smith’s personal life, wife &amp; about his kids." /><meta property="og:url" content="https://chilloutradio.com/will-smith/" /><meta property="og:site_name" content="Chillout Radio" /><meta property="article:publisher" content="https://www.facebook.com/ChilloutRadioCom/" /><meta property="article:published_time" content="2020-11-12T09:34:15+00:00" /><meta property="og:image" content="https://chilloutradio.com/wp-content/uploads/2019/12/Will-Smith.jpg" /><meta property="og:image:width" content="408" /><meta property="og:image:height" content="599" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@ChilloutRadioco" /><meta name="twitter:site" content="@ChilloutRadioco" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Chillout Radio"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="6 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://chilloutradio.com/#organization","name":"Chillout Radio","url":"https://chilloutradio.com/","sameAs":["https://www.facebook.com/ChilloutRadioCom/","https://www.instagram.com/chilloutradiocom/","https://www.linkedin.com/company/chilloutradio","https://apps.apple.com/app/chillout-radio/id1492096666","https://www.pinterest.com/chilloutradio/","https://play.google.com/store/apps/details?id=com.radio.m969ab7845","https://twitter.com/ChilloutRadioco"],"logo":{"@type":"ImageObject","@id":"https://chilloutradio.com/#logo","inLanguage":"en-AU","url":"https://chilloutradio.com/wp-content/uploads/2019/11/chill-out-radio-logo.png","width":490,"height":97,"caption":"Chillout Radio"},"image":{"@id":"https://chilloutradio.com/#logo"}},{"@type":"WebSite","@id":"https://chilloutradio.com/#website","url":"https://chilloutradio.com/","name":"Chillout Radio","description":"","publisher":{"@id":"https://chilloutradio.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://chilloutradio.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-AU"},{"@type":"ImageObject","@id":"https://chilloutradio.com/will-smith/#primaryimage","inLanguage":"en-AU","url":"https://chilloutradio.com/wp-content/uploads/2019/12/Will-Smith.jpg","width":408,"height":599,"caption":"Will Smith, Soccer.Ru, Wikimedia Commons"},{"@type":"WebPage","@id":"https://chilloutradio.com/will-smith/#webpage","url":"https://chilloutradio.com/will-smith/","name":"Will Smith - Primetime Academy Award American Actor","isPartOf":{"@id":"https://chilloutradio.com/#website"},"primaryImageOfPage":{"@id":"https://chilloutradio.com/will-smith/#primaryimage"},"datePublished":"2020-11-12T09:34:15+00:00","dateModified":"2020-11-12T09:34:15+00:00","description":"Everyting about Will Smith actor, including: age, education, religion, movies, Will Smith\u2019s personal life, wife & about his kids.","inLanguage":"en-AU","potentialAction":[{"@type":"ReadAction","target":["https://chilloutradio.com/will-smith/"]}]},{"@type":["Article","NewsArticle"],"@id":"https://chilloutradio.com/will-smith/#article","isPartOf":{"@id":"https://chilloutradio.com/will-smith/#webpage"},"author":{"@id":"https://chilloutradio.com/#/schema/person/21701901958987f487ee25c4bba75f6f"},"headline":"Everything you need to know about Will Smith","datePublished":"2020-11-12T09:34:15+00:00","dateModified":"2020-11-12T09:34:15+00:00","mainEntityOfPage":{"@id":"https://chilloutradio.com/will-smith/#webpage"},"publisher":{"@id":"https://chilloutradio.com/#organization"},"image":{"@id":"https://chilloutradio.com/will-smith/#primaryimage"},"articleSection":"Actors","inLanguage":"en-AU","copyrightYear":"2020","copyrightHolder":{"@id":"https://chilloutradio.com/#organization"}},{"@type":"Person","@id":"https://chilloutradio.com/#/schema/person/21701901958987f487ee25c4bba75f6f","name":"Chillout Radio","image":{"@type":"ImageObject","@id":"https://chilloutradio.com/#personlogo","inLanguage":"en-AU","url":"https://secure.gravatar.com/avatar/3560cc52040a2f50e6b6990a2f3ee51d?s=96&d=mm&r=g","caption":"Chillout Radio"}}]}</script> <link rel='dns-prefetch' href='//www.google.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Chillout Radio &raquo; Feed" href="https://chilloutradio.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Chillout Radio &raquo; Comments Feed" href="https://chilloutradio.com/comments/feed/" /> <script type='text/javascript' src='https://chilloutradio.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://chilloutradio.com/wp-json/" /><link rel="alternate" type="application/json" href="https://chilloutradio.com/wp-json/wp/v2/post/4569" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chilloutradio.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://chilloutradio.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.5.3" /><link rel='shortlink' href='https://chilloutradio.com/?p=4569' /><link rel="alternate" type="application/json+oembed" href="https://chilloutradio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchilloutradio.com%2Fwill-smith%2F" /><link rel="alternate" type="text/xml+oembed" href="https://chilloutradio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchilloutradio.com%2Fwill-smith%2F&#038;format=xml" /> <script type="text/javascript">jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://chilloutradio.com/front.js");
                  }
              });</script> <meta property="fb:app_id" content="110250357103055" /><meta property="fb:admins" content="100001851521707" />  <script language="JavaScript">/**
   * Open centered pop-up window
   * By Arthur Gareginyan (arthurgareginyan@gmail.com)
   * For full source code, visit https://mycyberuniverse.com
   *
   * @param URL - specifies the URL of the page to open. If no URL is specified, a new window with about:blank will be opened
   * @param windowName - specifies the target attribute or the name of the window (_blank, _parent, _self, _top, name)
   * @param windowWidth - the window width in pixels (integer)
   * @param windowHeight - the window height in pixels (integer)
   */
   function popUpWindow(URL, windowName, windowWidth, windowHeight) {
    var centerLeft = (screen.width/2)-(windowWidth/2);
    var centerTop = (screen.height/2)-(windowHeight/2);
    var windowFeatures = 'toolbar=no, location=no, directories=no, status=no, menubar=no, titlebar=no, scrollbars=no, resizable=no, ';
    return window.open(URL, windowName, windowFeatures +' width='+ windowWidth +', height='+ windowHeight +', top='+ centerTop +', left='+ centerLeft);
   }</script> <meta name="viewport" content="width=device-width, initial-scale=1"><link rel="amphtml" href="https://chilloutradio.com/will-smith/amp/"><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://chilloutradio.com/will-smith/?amp=1"><link rel="icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-32x32.png" sizes="32x32" /><link rel="icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-180x180.png" /><meta name="msapplication-TileImage" content="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-270x270.png" />  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-152700446-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-152700446-1');</script>  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '318697615187585');
  fbq('track', 'PageView');</script>  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '318697615187585');
  fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
 src="https://www.facebook.com/tr?id=318697615187585&ev=PageView&noscript=1"
/></noscript></head><body itemtype='https://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-4569 single-format-standard wp-custom-logo post-image-above-header post-image-aligned-center lalita-button-radius-full  featured-image-active right-sidebar nav-float-right fluid-header one-container active-footer-widgets-3 nav-aligned-right header-aligned-left dropdown-hover navigation-effect-none elementor-default elementor-kit-5710"><div class="lalita-side-padding-inside"> <a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a><div class="top-bar top-bar-align-left"><div class="inside-top-bar grid-container grid-parent"><aside id="text-2" class="widget inner-padding widget_text"><div class="textwidget"></div></aside><div class="lalita-social-bar"><ul class="lalita-socials-list"><li><a href="https://www.facebook.com/ChilloutRadioCom" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-facebook-square"></i></a></li><li><a href="https://twitter.com/ChilloutRadioco" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-twitter"></i></a></li><li><a href="https://www.linkedin.com/company/chilloutradio" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-linkedin"></i></a></li></ul></div></div></div><header itemtype="https://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header"<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><div class="inside-header grid-container grid-parent"><div class="header-content-h"><div class="site-logo"> <a href="https://chilloutradio.com/" title="Chillout Radio" data-wpel-link="internal"> <img  class="header-image" src="https://chilloutradio.com/wp-content/uploads/2019/11/chill-out-radio-logo.png" title="Chillout Radio" /> </a></div><nav itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation"><div class="inside-navigation grid-container grid-parent"> <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"> <span class="mobile-menu">Menu</span> </button><div id="primary-menu" class="main-nav"><ul id="menu-main" class=" menu sf-menu"><li id="menu-item-7053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7053"><a href="https://chilloutradio.com/artists/" data-wpel-link="internal">Artists</a></li><li id="menu-item-6342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6342"><a href="https://chilloutradio.com/interviews/" data-wpel-link="internal">Interviews</a></li><li id="menu-item-6341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6341"><a href="https://chilloutradio.com/reviews/" data-wpel-link="internal">Reviews</a></li><li id="menu-item-7057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7057"><a href="https://chilloutradio.com/best-song/" data-wpel-link="internal">Best Song</a></li><li id="menu-item-7055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7055"><a href="https://chilloutradio.com/fun/" data-wpel-link="internal">Fun</a></li><li id="menu-item-4108" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-4108"><a href="https://chilloutradio.com/news/" data-wpel-link="internal">Worth Reading</a></li><li id="menu-item-7054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7054"><a href="#">Get in touch<span role="presentation" class="dropdown-menu-toggle"></span></a><ul class="sub-menu"><li id="menu-item-4057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4057"><a href="https://chilloutradio.com/about-us/" data-wpel-link="internal">About Us</a></li><li id="menu-item-4132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4132"><a href="https://chilloutradio.com/our-team/" data-wpel-link="internal">Our Team</a></li><li id="menu-item-4056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4056"><a href="https://chilloutradio.com/contact/" data-wpel-link="internal">Contact</a></li></ul></li></ul></div></div></nav></div></div></header><div id="page" class="hfeed site grid-container container grid-parent"><div id="content" class="site-content"><div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75"><main id="main" class="site-main"><article id="post-4569" class="post-4569 post type-post status-publish format-standard has-post-thumbnail hentry category-actors" itemtype='https://schema.org/CreativeWork' itemscope='itemscope'><div class="inside-article"><div class="featured-image  page-header-image-single "> <img width="408" height="599" src="https://chilloutradio.com/wp-content/uploads/2019/12/Will-Smith.jpg" class="attachment-full size-full" alt="Will Smith" loading="lazy" itemprop="image" srcset="https://chilloutradio.com/wp-content/uploads/2019/12/Will-Smith.jpg 408w, https://chilloutradio.com/wp-content/uploads/2019/12/Will-Smith-204x300.jpg 204w" sizes="(max-width: 408px) 100vw, 408px" /></div> <span class="featured-image-caption"> <i class="fas fa-camera"></i> Will Smith, Soccer.Ru, Wikimedia Commons </span><header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><h1 class="entry-title" itemprop="headline">Everything you need to know about Will Smith</h1><div class="entry-meta"> <span class="posted-on"><a href="https://chilloutradio.com/will-smith/" title="" rel="bookmark" data-wpel-link="internal"><time class="updated" datetime="" itemprop="dateModified"></time><time class="entry-date published" datetime="" itemprop="datePublished"></time></a></span> <span class="byline"><span class="author vcard" itemtype="https://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="https://chilloutradio.com/author/admin/" title="View all posts by " rel="author" itemprop="url" data-wpel-link="internal"><span class="author-name" itemprop="name"></span></a></span></span></div></header><div class="entry-content" itemprop="text"><div id="fb-root"></div><h2>Will Smith’s Full Name</h2><h3>What is Will Smith’s full name?</h3><p>Will Smith’s full name is Willard Carroll Smith Jr., he shares his name with his father, Willard Carroll Smith Sr. and has passed his name onto his son, who goes by the name Trey instead. Smith uses the shorted ‘Will’ is his professional career, a common choice for actor’s with longer names.</p><h2>Will Smith’s Age</h2><h3>What is Will Smith’s age?</h3><p>Will Smith was born on the 25<sup>th</sup> of September, 1968 and is currently 51 years of age. Will Smith was born in Philadelphia, Pennsylvania. Will Smith has become a bit more of a silver fox in recent year, showing signs of his age with salt and pepper hair but still looks exceptionally young for his age. In his upcoming film, Gemini Man, his age was wound back to 23 years through digital recreation.</p><h2>Will Smith’s Family</h2><figure id="attachment_5112" aria-describedby="caption-attachment-5112" style="width: 890px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-5112" src="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-family.jpg" alt="Will Smith family" width="900" height="682" srcset="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-family.jpg 900w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-family-300x227.jpg 300w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-family-768x582.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><figcaption id="caption-attachment-5112" class="wp-caption-text">LOS ANGELES &#8211; FEB 09: WILL SMITH, JADA PINKETT SMITH, JADEN SMITH &amp; WILLOW SMITH arrives to the &#8220;Justin Bieber: Never Say Never&#8221; Los Angeles Premiere on February 08,2011 in Los Angeles, CA. Source: DFree, Bigstock.</figcaption></figure><h3>Who is Will Smith’s family?</h3><p>Will Smith mother is Caroline (nee Bright) a school board administrator from Philadelphia and his father is Willard Carroll Smith Sr., a US Air Force veteran and refrigeration technician. He also has an older sister, Pamela and two younger twin siblings, Harry and Ellen.</p><h2>Will Smith’s education</h2><h3>Where did Will Smith go to school?</h3><p>Will Smith went to school at Our Lady of Lourdes, a private Catholic elementary school in Philadelphia. He then went to Overbrook High School. It was reported that he later turned down a scholarship to MIT in order to pursue his <a href="https://chilloutradio.com/will-smith-raps-with-jimmy-fallon/" data-wpel-link="internal">rapping career</a>,  but he clarified that he never applied. He was admitted into a summer program for high school students but he didn’t go.</p><div data-ad-id="5713" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-5713  "><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
 style="display:block; text-align:center;"
 data-ad-layout="in-article"
 data-ad-format="fluid"
 data-ad-client="ca-pub-3672890885738962"
 data-ad-slot="5967603167"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><h2>Will Smith’s Residence</h2><h3>Where does Will Smith live?</h3><p>Will Smith’s main residence is located in Calabasas, LA. His home is a $42 million mansion which is very private but close to Hollywood. The mansion is completely custom designed and took seven years to build. It has 9 bedrooms, a meditation lounge, pool room, home theatre, recording studio, a basketball court, volleyball court, trampoline, outdoor pool and an eight car garage. The home also has a lake and a gazebo. The home takes up more than 25,000 square feet. He also owns a number of other properties.</p><h2>Will Smith’s height and weight</h2><figure id="attachment_5110" aria-describedby="caption-attachment-5110" style="width: 581px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-5110" src="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-height-and-weight.jpg" alt="Will Smith height and weight" width="591" height="900" srcset="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-height-and-weight.jpg 591w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-height-and-weight-197x300.jpg 197w" sizes="(max-width: 591px) 100vw, 591px" /><figcaption id="caption-attachment-5110" class="wp-caption-text">Will Smith arrives for the &#8220;Bright&#8221; Los Angeles Premiere on December 13, 2017 in Westwood, CA. Source: DFree, Bigstock.</figcaption></figure><h3>What is Will Smith’s height and weight?</h3><p>Will Smith is around 6 feet 1 inch tall, or 187 cm and usually weighs around 82kg’s, although his weight fluctuates depending on his roles. He has bulked up in the past for movie roles, most recently Aladdin. He recently admitted that he had gained a lot of weight after finishing filming for Aladdin, ballooning up to 102kgs thanks to a diet of muffins. He lost the weight with a 10 day fast after his family started calling him ‘Pudge Muffin’.</p><h2>Will Smith’s nationality</h2><h3>What nationality is Will Smith?</h3><p>Will Smith was born in Philadelphia and is an American. He is an African American man and both of his parents were African-American. His children also have both paternal and maternal African-American heritage.</p><h2>Will Smith’s religion</h2><h3>What religion does Will Smith follow?</h3><p>Will Smith was born in a Baptist home and went to a Catholic School. He admitted in 2013 that he was not religious but expressed some affinity for Christianity in 2015 when discussing his Grandmother. He has also come out to deny that he is a Scientologist but has spoken positively about the religion in the past.</p><h2>Will Smith’s fame</h2><figure id="attachment_5111" aria-describedby="caption-attachment-5111" style="width: 590px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-5111" src="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-fame.jpg" alt="Will Smith fame" width="600" height="900" srcset="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-fame.jpg 600w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-fame-200x300.jpg 200w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption id="caption-attachment-5111" class="wp-caption-text">Will Smith with Jada Pinkett Smith and her band &#8216;Wicked Wisdom&#8217; perform on stage at Grove in Los Angeles in 2004. Source: Starfrenzy, Bigstock.</figcaption></figure><h3>What is Will Smith famous for?</h3><p>Will Smith is famous for being an American actor and rapper. He has been called the most powerful actor in Hollywood. He is a highly <a href="https://chilloutradio.com/grammy-awards/" data-wpel-link="internal">awarded actor and has won four Grammy Awards</a> during his career. He has also attracted five <a href="https://chilloutradio.com/the-golden-globes/" data-wpel-link="internal">Golden Globe</a> Award nomination and two Academy Award nominations.</p><h2>Will Smith’s early career</h2><p><iframe title="The Fresh Prince Of Bel Air Theme Song (Full)" width="877" height="658" src="https://www.youtube.com/embed/1nCqRmx3Dnw?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><h3>How did Will Smith’s career start?</h3><p>Will Smith’s career first started when he was one half of the hip-hop duo, DJ Jazzy Jeff &amp; The Fresh Prince. Will Smith built a reputation for his story-telling raps and profanity-free battle rhymes. The duos first album won a Grammy in 1989. Smith was later signed on to the sitcom, The Fresh Prince of Bel Air.</p><h2>Will Smith’s breakthrough role</h2><h3>What was Will Smith’s breakthrough role?</h3><p>Smith first big film role was in Six Degrees of Separation and in Bad Boys – which was commercially successful. He later joined an ensemble cast in Independence Day, a huge block buster film. In 1997 he starred in Men In Black, a huge block buster film – by this point he had cemented his status as a leading man. He continued releasing music during this time, including hits like Men in Black and Gettin’ Jiggy With It.</p><h2>Will Smith’s continued film success</h2><figure id="attachment_5113" aria-describedby="caption-attachment-5113" style="width: 890px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-5113" src="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-continued-film-success.jpg" alt="Will Smith continued film success" width="900" height="598" srcset="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-continued-film-success.jpg 900w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-continued-film-success-300x199.jpg 300w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-continued-film-success-768x510.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><figcaption id="caption-attachment-5113" class="wp-caption-text">Will Smith at the World Premiere of &#8220;Hancock&#8221;. Grauman&#8217;s Chinese Theatre, Hollywood, CA. Source: S_bukley, Bigstock.</figcaption></figure><h3>What has Will Smith done since his breakthrough role?</h3><p>Will Smith career continued to grow from strength to strength, he did miss out on the role of Neo in the Matrix however. He continued releasing music, coming out with W2K, which reached number 25 on the Hot 100. He portrayed Muhammad Ali in Ali and appeared in the sequel to Men in Black and Bad Boys. He also appeared in I Am Legend, Hancock and After Earth more recently. In 2015 he starred alongside Margot Robbie in Focus, and appeared as Dead Shot in Suicide Squad. His next film was Bright, a Netflix movie. He most recently portrayed the genie in Aladdin and an assassin in Gemini Man.</p><h2>Will Smith’s net worth</h2><h3>What is Will Smith’s net worth?</h3><p>Will Smith is currently estimated to be worth $350 million. He earns $40 million every year, although it can be as much as $80 million. His income comes from his musical and acting pursuits as well as his significant real estate investments.</p><h2>Will Smith’s personal life</h2><figure id="attachment_5109" aria-describedby="caption-attachment-5109" style="width: 890px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-5109" src="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-personal-life.jpg" alt="Will Smith personal life" width="900" height="600" srcset="https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-personal-life.jpg 900w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-personal-life-300x200.jpg 300w, https://chilloutradio.com/wp-content/uploads/2020/01/Will-Smith-personal-life-768x512.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><figcaption id="caption-attachment-5109" class="wp-caption-text">Trey Smith, Jaden Smith, Jada Pinkett Smith and Will Smith at the &#8220;Aladdin&#8221; Premiere at the El Capitan Theater on May 21, 2019 in Los Angeles, CA. Source: Kathclick, Bigstock.</figcaption></figure><h3>Who has Will Smith married?</h3><p>Will Smith’s first marriage was to Sheree Zampino in 1992, the couple divorced in 1995. There were rumors that their relationship ended due to infidelity and drug use but both Will Smith and Sheree Zampino deny them, Sheree instead indicated that they simply got married too young. Will Smith then went on to marry Jada Pinkett in 1997. The couple is still together and live in LA together. Jada Pinkett and Will Smith’s ex-wife did not get on at first, admitting that they exchanged ‘fighting words’ initially, they are now a happy blended family with the couple even attending Sheree’s 50<sup>th</sup> birthday.</p><h3>Who has Will Smith dated?</h3><p>Will Smith has previously dated model Tyra Banks, for around a year between 1993 and 1994 and Garcelle Beauvais between 1990 and 1991. He also briefly dated Nia Long. There were rumors that he hooked up with Margot Robbie in 2013 on the set of Focus, although they remain unconfirmed. There were also reports that he’d hooked up with Karrine Steffans and Debbie Allen.</p><h3>Does Will Smith have kids?</h3><p>Will Smith has one child with ex-wife Sheree Zampino, Trey Smith (full name Willard Carroll Smith III) who was born in 1992. He has acted a few times, first appearing in one of his father’s <a href="https://chilloutradio.com/best-music-videos-of-all-time/" data-wpel-link="internal">music videos</a> and is now a successful DJ. Will Smith also has two children with his wife Jada Pinkett, Jaden Smith, who was born in 1998 and Willow Smith, born in 2000. Jaden Smith has appeared alongside his father in the film After Earth and Willow Smith is a singer.</p><p><em>Read more at <a href="https://chilloutradio.com/" data-wpel-link="internal">Chillout Radio</a></em></p><div class='heateorFfcpClear'></div><div style='width:100%;text-align:left;' class='heateor_ffcp_facebook_comments'><h4 class='heateor_ffcp_facebook_comments_title' style='padding:10px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;' >What do you think about it?</h4><script type="text/javascript">!function(e,n,t){var o,c=e.getElementsByTagName(n)[0];e.getElementById(t)||(o=e.createElement(n),o.id=t,o.src="//connect.facebook.net/en_AU/sdk.js#xfbml=1&version=v8.0",c.parentNode.insertBefore(o,c))}(document,"script","facebook-jssdk");</script><div class="fb-comments" data-href="https://chilloutradio.com/will-smith/" data-colorscheme="light" data-numposts="" data-width="100%" data-order-by="social" ></div><script type="text/javascript">jQuery(window).load(function(){null!=heateorFfcpGetCookie("heateorFfcpOptin")&&jQuery("input.heateor_ffcp_fb_comments_optin").prop("checked",!0),jQuery("input.heateor_ffcp_fb_comments_optin").click(function(){if(jQuery(this).is(":checked")){if(heateorFfcpOptin=1,null==heateorFfcpGetCookie("heateorFfcpOptin")){var e=new Date;e.setTime(e.getTime()+31536e6),document.cookie="heateorFfcpOptin=1; expires="+e.toUTCString()+"; path=/"}}else heateorFfcpOptin=0,document.cookie="heateorFfcpOptin=; expires=Fri, 02 Jan 1970 00:00:00 UTC; path=/"});});</script></div><div class='heateorFfcpClear'></div></div><footer class="entry-meta"> <span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://chilloutradio.com/actors/" rel="category tag" data-wpel-link="internal">Actors</a></span><nav id="nav-below" class="post-navigation"> <span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="prev" title="Previous"><a href="https://chilloutradio.com/will-smith-raps-with-jimmy-fallon/" rel="prev" data-wpel-link="internal">Will Smith raps with Jimmy Fallon</a></span></div></nav></footer></div></article></main></div><div id="right-sidebar" itemtype="https://schema.org/WPSideBar" itemscope="itemscope" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar"><div class="inside-right-sidebar"><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://chilloutradio.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"> </label> <input type="submit" class="search-submit" value="Search"></form></aside><aside id="recent-posts-2" class="widget inner-padding widget_recent_entries"><h2 class="widget-title">Latest:</h2><ul><li> <a href="https://chilloutradio.com/will-smith/" aria-current="page" data-wpel-link="internal">Everything you need to know about Will Smith</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/will-smith-raps-with-jimmy-fallon/" data-wpel-link="internal">Will Smith raps with Jimmy Fallon</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/pearl-jam-are-back-with-the-announcement-of-their-eleventh-studio-album-gigaton/" data-wpel-link="internal">Pearl Jam are back with the announcement of their eleventh studio album ‘Gigaton’</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/ladi-annes-debut-single-new-renaissance-is-hypnotically-brilliant/" data-wpel-link="internal">Ladi Anne’s debut single “New Renaissance” is hypnotically brilliant</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/tupac-shakur/" data-wpel-link="internal">All about Tupac Shakur the legendary rapper</a> <span class="post-date"></span></li></ul></aside><aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-3672890885738962"
 data-ad-slot="1198298697"
 data-ad-format="auto"
 data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="categories-2" class="widget inner-padding widget_categories"><h2 class="widget-title">Read by categories:</h2><ul><li class="cat-item cat-item-146"><a href="https://chilloutradio.com/actors/" data-wpel-link="internal">Actors</a></li><li class="cat-item cat-item-147"><a href="https://chilloutradio.com/music-artists/" data-wpel-link="internal">Artists</a></li><li class="cat-item cat-item-152"><a href="https://chilloutradio.com/best-song/" data-wpel-link="internal">Best Song</a></li><li class="cat-item cat-item-98"><a href="https://chilloutradio.com/celebrity/" data-wpel-link="internal">Celebrity</a></li><li class="cat-item cat-item-3"><a href="https://chilloutradio.com/entertainment/" data-wpel-link="internal">Entertainment</a></li><li class="cat-item cat-item-151"><a href="https://chilloutradio.com/fun/" data-wpel-link="internal">Fun</a></li><li class="cat-item cat-item-150"><a href="https://chilloutradio.com/interviews/" data-wpel-link="internal">Interviews</a></li><li class="cat-item cat-item-4"><a href="https://chilloutradio.com/living/" data-wpel-link="internal">Living</a></li><li class="cat-item cat-item-1"><a href="https://chilloutradio.com/people/" data-wpel-link="internal">People</a></li><li class="cat-item cat-item-149"><a href="https://chilloutradio.com/reviews/" data-wpel-link="internal">Reviews</a></li><li class="cat-item cat-item-2"><a href="https://chilloutradio.com/style/" data-wpel-link="internal">Style</a></li></ul></aside><aside id="text-7" class="widget inner-padding widget_text"><h2 class="widget-title">Newsletter:</h2><div class="textwidget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-6325 mc4wp-form-theme mc4wp-form-theme-blue" method="post" data-id="6325" data-name="Chill" ><div class="mc4wp-form-fields"><p> <label>Your name:</label> <input type="text" name="FNAME"></p><p> <label>Email address: <input type="email" name="EMAIL" placeholder="Your email address" required /> </label></p><p> <input type="submit" value="Sign up" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1605229204" /><input type="hidden" name="_mc4wp_form_id" value="6325" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div></aside></div></div></div></div><div class="site-footer  "><div id="footer-widgets" class="site footer-widgets"><div class="footer-widgets-container grid-container grid-parent"><div class="inside-footer-widgets"><div class="footer-widget-1 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-5" class="widget inner-padding widget_text"><h2 class="widget-title">Listing Online</h2><div class="textwidget"><p><img loading="lazy" class="alignnone wp-image-4352 size-full" src="https://chilloutradio.com/wp-content/uploads/2019/12/apple.png" alt="download apple chillout music radio" width="180" height="68" /><br /> <img loading="lazy" class="alignleft wp-image-4353 size-full" src="https://chilloutradio.com/wp-content/uploads/2019/12/android.png" alt="listing to chillout radio station on android" width="180" height="68" /></p></div></aside></div><div class="footer-widget-2 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-4" class="widget inner-padding widget_text"><h2 class="widget-title">Contact</h2><div class="textwidget"><p>Get in touch with us by submitting the contact form <a href="https://chilloutradio.com/contact/" data-wpel-link="internal">here</a>.</p></div></aside></div><div class="footer-widget-3 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-3" class="widget inner-padding widget_text"><h2 class="widget-title">Legal</h2><div class="textwidget"><ul><li><a href="https://chilloutradio.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li><li><a href="https://chilloutradio.com/terms-of-use/" data-wpel-link="internal">Terms Of Use</a></li><li><a href="https://chilloutradio.com/feedback-and-complaints/" data-wpel-link="internal">Feedback and Complaints</a></li></ul></div></aside></div></div></div></div><footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope="itemscope"><div class="inside-site-info grid-container grid-parent"><div class="copyright-bar"> <span class="copyright">&copy; 2020 Chillout Radio</span></div></div></footer></div> <a title="Scroll back to top" rel="nofollow" href="#" class="lalita-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300"> <span class="screen-reader-text">Scroll back to top</span> </a><div class="lalita-side-left-cover"></div><div class="lalita-side-right-cover"></div></div> <script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script> <div id="amp-mobile-version-switcher" hidden> <a rel="amphtml" href="https://chilloutradio.com/will-smith/?amp=1" data-wpel-link="internal"> Go to mobile version </a></div> <script type='text/javascript' id='adsforwp-ads-front-js-js-extra'>var adsforwp_obj = {"ajax_url":"https:\/\/chilloutradio.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"409e90849c"};</script> <script type='text/javascript' id='adsforwp-ads-frontend-js-js-extra'>var adsforwp_browser_obj = [];</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"apiSettings":{"root":"https:\/\/chilloutradio.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script type='text/javascript' id='wpcf7-redirect-script-js-extra'>var wpcf7r = {"ajax_url":"https:\/\/chilloutradio.com\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lcm7bEZAAAAAMxEmHKhoBfZglBaLmKD-hLTwXN_&#038;ver=3.0' id='google-recaptcha-js'></script> <script type='text/javascript' id='wpcf7-recaptcha-js-extra'>var wpcf7_recaptcha = {"sitekey":"6Lcm7bEZAAAAAMxEmHKhoBfZglBaLmKD-hLTwXN_","actions":{"homepage":"homepage","contactform":"contactform"}};</script> <!--[if lte IE 11]> <script type='text/javascript' src='https://chilloutradio.com/wp-content/themes/lalita/js/classList.min.js?ver=1.1.1' id='lalita-classlist-js'></script> <![endif]--> <script defer src="https://chilloutradio.com/wp-content/cache/autoptimize/js/autoptimize_a30432875046cc8f2e2df385a4e0be78.js"></script></body></html>
<!-- Page generated by LiteSpeed Cache 3.5.2 on 2020-11-13 12:00:04 -->