<!DOCTYPE html><html lang="en-AU"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge" /><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Work+Sans:100,200,300,regular,500,600,700,800,900%7CPermanent+Marker:regular%7CBowlby+One:regular&amp;display=swap" /><link rel="profile" href="http://gmpg.org/xfn/11"> <script type="text/javascript">var heateorFfcpAjaxUrl = 'https://chilloutradio.com/wp-admin/admin-ajax.php', heateorFfcpWebsiteUrl = 'https://chilloutradio.com';</script> <link media="all" href="https://chilloutradio.com/wp-content/cache/autoptimize/css/autoptimize_9a23259bb88782a83d8840222ad6ab1e.css" rel="stylesheet" /><title>Jim Morrison - Lead Singer of The Doors, Songwriter, Poet</title><meta name="description" content="Jim Morrison was famous for being the lead singer of The Doors, his poetry, and remembered as one of the most influential lead singers in the rock history." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://chilloutradio.com/?p=7132" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Jim Morrison - Lead Singer of The Doors, Songwriter, Poet" /><meta property="og:description" content="Jim Morrison was famous for being the lead singer of The Doors, his poetry, and remembered as one of the most influential lead singers in the rock history." /><meta property="og:url" content="https://chilloutradio.com/?p=7132" /><meta property="og:site_name" content="Chillout Radio" /><meta property="article:publisher" content="https://www.facebook.com/ChilloutRadioCom/" /><meta property="article:published_time" content="2020-08-07T18:00:40+00:00" /><meta property="article:modified_time" content="2020-07-26T00:35:56+00:00" /><meta property="og:image" content="https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison.jpg" /><meta property="og:image:width" content="477" /><meta property="og:image:height" content="549" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@ChilloutRadioco" /><meta name="twitter:site" content="@ChilloutRadioco" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://chilloutradio.com/#organization","name":"Chillout Radio","url":"https://chilloutradio.com/","sameAs":["https://www.facebook.com/ChilloutRadioCom/","https://www.instagram.com/chilloutradiocom/","https://www.linkedin.com/company/chilloutradio","https://apps.apple.com/app/chillout-radio/id1492096666","https://www.pinterest.com/chilloutradio/","https://play.google.com/store/apps/details?id=com.radio.m969ab7845","https://twitter.com/ChilloutRadioco"],"logo":{"@type":"ImageObject","@id":"https://chilloutradio.com/#logo","inLanguage":"en-AU","url":"https://chilloutradio.com/wp-content/uploads/2019/11/chill-out-radio-logo.png","width":490,"height":97,"caption":"Chillout Radio"},"image":{"@id":"https://chilloutradio.com/#logo"}},{"@type":"WebSite","@id":"https://chilloutradio.com/#website","url":"https://chilloutradio.com/","name":"Chillout Radio","description":"","publisher":{"@id":"https://chilloutradio.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://chilloutradio.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-AU"},{"@type":"ImageObject","@id":"https://chilloutradio.com/?p=7132#primaryimage","inLanguage":"en-AU","url":"https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison.jpg","width":477,"height":549,"caption":"Jim Morrison while performing"},{"@type":"WebPage","@id":"https://chilloutradio.com/?p=7132#webpage","url":"https://chilloutradio.com/?p=7132","name":"Jim Morrison - Lead Singer of The Doors, Songwriter, Poet","isPartOf":{"@id":"https://chilloutradio.com/#website"},"primaryImageOfPage":{"@id":"https://chilloutradio.com/?p=7132#primaryimage"},"datePublished":"2020-08-07T18:00:40+00:00","dateModified":"2020-07-26T00:35:56+00:00","description":"Jim Morrison was famous for being the lead singer of The Doors, his poetry, and remembered as one of the most influential lead singers in the rock history.","inLanguage":"en-AU","potentialAction":[{"@type":"ReadAction","target":["https://chilloutradio.com/?p=7132"]}]},{"@type":"NewsArticle","@id":"https://chilloutradio.com/?p=7132#article","isPartOf":{"@id":"https://chilloutradio.com/?p=7132#webpage"},"author":{"@id":"https://chilloutradio.com/#/schema/person/21701901958987f487ee25c4bba75f6f"},"headline":"Everything you need to know about Jim Morrison","datePublished":"2020-08-07T18:00:40+00:00","dateModified":"2020-07-26T00:35:56+00:00","mainEntityOfPage":{"@id":"https://chilloutradio.com/?p=7132#webpage"},"publisher":{"@id":"https://chilloutradio.com/#organization"},"image":{"@id":"https://chilloutradio.com/?p=7132#primaryimage"},"articleSection":"Artists","inLanguage":"en-AU","copyrightYear":"2020","copyrightHolder":{"@id":"https://chilloutradio.com/#organization"}},{"@type":["Person"],"@id":"https://chilloutradio.com/#/schema/person/21701901958987f487ee25c4bba75f6f","name":"Chillout Radio","image":{"@type":"ImageObject","@id":"https://chilloutradio.com/#personlogo","inLanguage":"en-AU","url":"https://secure.gravatar.com/avatar/3560cc52040a2f50e6b6990a2f3ee51d?s=96&d=mm&r=g","caption":"Chillout Radio"}}]}</script> <link rel='dns-prefetch' href='//www.google.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Chillout Radio &raquo; Feed" href="https://chilloutradio.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Chillout Radio &raquo; Comments Feed" href="https://chilloutradio.com/comments/feed/" /> <script type='text/javascript' src='https://chilloutradio.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <link rel='https://api.w.org/' href='https://chilloutradio.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://chilloutradio.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://chilloutradio.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://chilloutradio.com/?p=7132' /><link rel="alternate" type="application/json+oembed" href="https://chilloutradio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchilloutradio.com%2Fjim-morrison%2F" /><link rel="alternate" type="text/xml+oembed" href="https://chilloutradio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fchilloutradio.com%2Fjim-morrison%2F&#038;format=xml" /> <script type="text/javascript">jQuery(document).ready( function($) {    
                  if ($('#adsforwp-hidden-block').length == 0 ) {
                       $.getScript("https://chilloutradio.com/front.js");
                  }
              });</script> <meta property="fb:app_id" content="110250357103055" /><meta property="fb:admins" content="100001851521707" />  <script language="JavaScript">/**
   * Open centered pop-up window
   * By Arthur Gareginyan (arthurgareginyan@gmail.com)
   * For full source code, visit https://mycyberuniverse.com
   *
   * @param URL - specifies the URL of the page to open. If no URL is specified, a new window with about:blank will be opened
   * @param windowName - specifies the target attribute or the name of the window (_blank, _parent, _self, _top, name)
   * @param windowWidth - the window width in pixels (integer)
   * @param windowHeight - the window height in pixels (integer)
   */
   function popUpWindow(URL, windowName, windowWidth, windowHeight) {
    var centerLeft = (screen.width/2)-(windowWidth/2);
    var centerTop = (screen.height/2)-(windowHeight/2);
    var windowFeatures = 'toolbar=no, location=no, directories=no, status=no, menubar=no, titlebar=no, scrollbars=no, resizable=no, ';
    return window.open(URL, windowName, windowFeatures +' width='+ windowWidth +', height='+ windowHeight +', top='+ centerTop +', left='+ centerLeft);
   }</script> <meta name="viewport" content="width=device-width, initial-scale=1"><link rel="amphtml" href="https://chilloutradio.com/jim-morrison/amp/"><link rel="icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-32x32.png" sizes="32x32" /><link rel="icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-180x180.png" /><meta name="msapplication-TileImage" content="https://chilloutradio.com/wp-content/uploads/2019/11/cropped-icon-270x270.png" />  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-152700446-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-152700446-1');</script>  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '318697615187585');
  fbq('track', 'PageView');</script>  <script>!function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '318697615187585');
  fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
 src="https://www.facebook.com/tr?id=318697615187585&ev=PageView&noscript=1"
/></noscript></head><body itemtype='https://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-7132 single-format-standard wp-custom-logo post-image-above-header post-image-aligned-center lalita-button-radius-full  featured-image-active right-sidebar nav-float-right fluid-header one-container active-footer-widgets-3 nav-aligned-right header-aligned-left dropdown-hover navigation-effect-none elementor-default"><div class="lalita-side-padding-inside"> <a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a><div class="top-bar top-bar-align-left"><div class="inside-top-bar grid-container grid-parent"><aside id="text-2" class="widget inner-padding widget_text"><div class="textwidget"></div></aside><div class="lalita-social-bar"><ul class="lalita-socials-list"><li><a href="https://www.facebook.com/ChilloutRadioCom" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-facebook-square"></i></a></li><li><a href="https://twitter.com/ChilloutRadioco" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-twitter"></i></a></li><li><a href="https://www.linkedin.com/company/chilloutradio" target="_blank" data-wpel-link="external" rel="nofollow"><i class="fa fa-linkedin"></i></a></li></ul></div></div></div><header itemtype="https://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header"<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><div class="inside-header grid-container grid-parent"><div class="header-content-h"><div class="site-logo"> <a href="https://chilloutradio.com/" title="Chillout Radio" data-wpel-link="internal"> <img  class="header-image" src="https://chilloutradio.com/wp-content/uploads/2019/11/chill-out-radio-logo.png" title="Chillout Radio" /> </a></div><nav itemtype="https://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation"><div class="inside-navigation grid-container grid-parent"> <button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"> <span class="mobile-menu">Menu</span> </button><div id="primary-menu" class="main-nav"><ul id="menu-main" class=" menu sf-menu"><li id="menu-item-7053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7053"><a href="https://chilloutradio.com/artists/" data-wpel-link="internal">Artists</a></li><li id="menu-item-6342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6342"><a href="https://chilloutradio.com/interviews/" data-wpel-link="internal">Interviews</a></li><li id="menu-item-6341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6341"><a href="https://chilloutradio.com/reviews/" data-wpel-link="internal">Reviews</a></li><li id="menu-item-7057" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7057"><a href="https://chilloutradio.com/best-song/" data-wpel-link="internal">Best Song</a></li><li id="menu-item-7055" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7055"><a href="https://chilloutradio.com/fun/" data-wpel-link="internal">Fun</a></li><li id="menu-item-4108" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-4108"><a href="https://chilloutradio.com/news/" data-wpel-link="internal">Worth Reading</a></li><li id="menu-item-7054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7054"><a href="#">Get in touch<span role="presentation" class="dropdown-menu-toggle"></span></a><ul class="sub-menu"><li id="menu-item-4057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4057"><a href="https://chilloutradio.com/about-us/" data-wpel-link="internal">About Us</a></li><li id="menu-item-4132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4132"><a href="https://chilloutradio.com/our-team/" data-wpel-link="internal">Our Team</a></li><li id="menu-item-4056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4056"><a href="https://chilloutradio.com/contact/" data-wpel-link="internal">Contact</a></li></ul></li><li id="menu-item-4193" class="menu-item menu-item-type-gs_sim menu-item-object-gs_sim menu-item-4193"><a onclick="popUpWindow(&#039;https://chilloutradio.com/listing/&#039;,&#039;Example&#039;,&#039;300&#039;,&#039;400&#039;);" href="javascript:void(0);" data-wpel-link="internal"><img class="alignnone wp-image-4189 size-full" src="https://chilloutradio.com/wp-content/uploads/2019/12/listen.png" alt="Listen Music" width="174" height="55" /></a></li></ul></div></div></nav></div></div></header><div id="page" class="hfeed site grid-container container grid-parent"><div id="content" class="site-content"><div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75"><main id="main" class="site-main"><article id="post-7132" class="post-7132 post type-post status-publish format-standard has-post-thumbnail hentry category-music-artists" itemtype='https://schema.org/CreativeWork' itemscope='itemscope'><div class="inside-article"><div class="featured-image  page-header-image-single "> <img width="477" height="549" src="https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison.jpg" class="attachment-full size-full" alt="Jim Morrison while performing" itemprop="image" srcset="https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison.jpg 477w, https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison-261x300.jpg 261w" sizes="(max-width: 477px) 100vw, 477px" /></div><header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><h1 class="entry-title" itemprop="headline">Everything you need to know about Jim Morrison</h1><div class="entry-meta"> <span class="posted-on"><a href="https://chilloutradio.com/jim-morrison/" title="" rel="bookmark" data-wpel-link="internal"><time class="updated" datetime="" itemprop="dateModified"></time><time class="entry-date published" datetime="" itemprop="datePublished"></time></a></span> <span class="byline"><span class="author vcard" itemtype="https://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="https://chilloutradio.com/author/admin/" title="View all posts by " rel="author" itemprop="url" data-wpel-link="internal"><span class="author-name" itemprop="name"></span></a></span></span></div></header><div class="entry-content" itemprop="text"><div id="fb-root"></div><h2>Jim Morrison’s Full Name</h2><h3>What was his full name?</h3><p>Though the singer is known by the common and less formal nickname ‘Jim’, his full name is actually James Douglas Morrison.</p><h2>Jim Morrison’s Age</h2><h3>How old was he?</h3><p>The singer was born on the 8<sup>th</sup> of December 1943 in Melbourne, Florida. He passed away on the 3<sup>rd</sup> of July 1971 in Paris at the age of 27. An autopsy was not performed and the cause of his death remains unknown.</p><h2>Jim Morrison’s Family</h2><h3>Who was his family?</h3><p>Jim Morrison is the son of Clara Virginia and George Stephen Morrison, a rear admiral in the U.S Navy. His father commanded the naval forces of the United States during the Gulf of Tonkin incident in August 1964, the incident provided the pretext for U.S involvement in the Vietnam War in 1965. The singer had two siblings, a younger sister, Anne Robin, and a younger brother Andrew Lee Morrison. At around three years old the singer witnessed a car accident in the desert where he saw Native American’s injured, he stated that the event was once of the most formative events of his life and he made repeated references to it in his music, poems, and interviews. His family however remembers the incident differently and his sister suggested that he had exaggerated the event.</p><h2>Jim Morrison’s Education</h2><h3>Where did he go to school?</h3><p>The singer was raised as a military kid and the family moved regularly. He spent some of his childhood in San Diego before completing third grade at Fairfax County Elementary School. He later attended school in Kingsville, Texas before continuing his education at St. John’s Methodist School in Albuquerque before attending Longfellow School Sixth Grade Graduation Program in San Diego. In 1957 he went to Alameda High School  before graduating from George Washington High School in Alexandria in 1961.</p><div data-ad-id="5713" style="text-align:center; margin-top:px; margin-bottom:px; margin-left:px; margin-right:px;float:none;" class="afw afw-ga afw_ad afwadid-5713  "><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
 style="display:block; text-align:center;"
 data-ad-layout="in-article"
 data-ad-format="fluid"
 data-ad-client="ca-pub-3672890885738962"
 data-ad-slot="5967603167"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div><h2>Jim Morrison’s religion</h2><h3>What was his religion?</h3><p>The singer was born into a Christian family but there constant moving around meant that his religious upbringing was disconnected and regularly disrupted. He dabbled in Shamanism as an adult as well as the occult and religious iconography regularly appears in his music. He has said in the past that he believes organized religion is ‘a bunch of bullshit’.</p><h2>Jim Morrison’s home</h2><h3>Where did he live?</h3><p>The singer’s home was first built in 1922 in Lauren Canyon Hills. The home is located only moments from Sunset Strip and is close to Rothdell Trail. The home was restored by the singer and nowadays is full of Doors history.</p><h2>Jim Morrison’s height and weight</h2><h3>What was height and weight?</h3><p>The singer is approximately 180 cm tall and although people regularly remember him as fit and healthy, he was heavier when he died due to heavy drinking, smoking, and drug use. The weight gain had taken a toll on his looks, changing his face and body dramatically by the time of his death.</p><h2>Jim Morrison’s fame</h2><h3>What was he famous for?</h3><p>The singer was famous for being the lead singer of The Doors, as well as for his songwriting and poetry. He is remembered as one of the most influential lead singers in rock history due to his poetic lyrics, erratic onstage presence, and the circumstances of his death. He is often associated with the generation gap and the youth counterculture of the 60s.</p><p>The singer recorded six albums with the band the Doors, all of which were critically acclaimed commercial successes. The band recorded more music after his death but split only two years later. The singer was inducted into the Rock and Roll Hall of Fame post-humously in 1993.</p><p>The singer was well known for giving improvised spoken word <a href="https://chilloutradio.com/most-famous-live-performances-of-all-time/" data-wpel-link="internal">performances during live</a> performances.</p><h2>Jim Morrison’s early career</h2><h3>How did his career start?</h3><p>The singer was interested in philosophy from a young age and the work of Friedrich Nietzsche, Plutarch, and French poet Arthur Rimbaud heavily influenced his work and poetry. The singer was also influenced by the likes of Willam S. Burroughs, Jack Kerouac, Allen Ginsberg, Louis Ferdinand Celine, Charles Baudelaire, Franz Kafka, Jean Coteau and many more. In 1964 the singer moved to Los Angeles to begin attending the University of California, Los Angeles, and enrolled in Jack Hirshman’s comparative literature program on Antonin Artaud. He completed his undergraduate degree at UCLA’s film school in 1965, during which he made a number of short films. Whilst living in Venice Beach he befriended a number of writers at the Los Angeles Free Press and conducted an interview of Bob Chorush and Andy Kent.</p><p>In the summer of 1965, Morrison was living a bohemian lifestyle in Venice Beach, where he lived on a rooftop and wrote many of the songs that the Doors later record and perform. Morrison and UCLA student Ray Manzarek were the first two members of the band, having met on the beach. Guitarist Robby Krieger and drummer John Densmore later joined. The band took their name from Aldous Huxley’s novel ‘The Doors of Perception’. In 1966 the band was the opening act at Whisky a Go-Go where he saw Van Morrison performed, becoming influenced by his style. In 1966 the band released the single ‘Break on through (to the other side’ and made a number of short films, ‘The Unknown Soldier’, ‘Moonlight Drive’ and ‘People are Strange’.</p><p><iframe title="The Doors - &quot;People Are Strange&quot; 1967 HD (Official Video) 1080P Jim Morrison" width="877" height="493" src="https://www.youtube.com/embed/sezc05A4s2g?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><h2>Jim Morrison’s career breakthrough</h2><h3>What was his career breakthrough?</h3><p>The band began to take off after they signed with Elektra Records in 1967 and their single ‘Light My Fire’ went to number one in the US on the Hot 100 charts. The band later appeared on ‘The Ed Sullivan Show’ where they were asked to edit the lyrics of their song because it could be perceived to be referencing drugs. The band gave assurances that they would change the lyrics but performed the original song on the show. Sullivan was angry and refused to shake the hands of the band members, saying that they would never reappear on the show.</p><p>By the time of the release of the band’s second album, the Doors had grown to become one of the most popular bands in the U.S. In 1966 Joel Brodsky took a number of black and white photos of Jim Morrison, the photos are considered to be some of the most iconic photographs in music history.</p><p>In 1968 the band released their third album ‘Waiting for the Sun’ and the following year performed for the first time in Europe. Their fourth album ‘The Soft Parade’ was released in 1969 and the band gave performances in England and Grenada. Around the same time, Morrison’s alcohol dependency worsened and he began to show up to recording sessions visibly drunk and was often late for live performances. In 1969 the singer tried to start a riot in Miami and the following day six arrest warrants were issued for him which caused a number of concerts to be canceled. After that, the singer lost his desire to perform and tried to quit a number of times. He was convicted and sentenced to six months prison for Miami but remained free on a $50,000 bond. He died only eight months later.</p><h2>Jim Morrison’s continued career success</h2><figure id="attachment_7471" aria-describedby="caption-attachment-7471" style="width: 566px" class="wp-caption alignnone"><img class="wp-image-7471 size-full" src="https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison2.jpg" alt="Jim Morrison performing on stage" width="576" height="551" srcset="https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison2.jpg 576w, https://chilloutradio.com/wp-content/uploads/2020/05/Jim-Morrison2-300x287.jpg 300w" sizes="(max-width: 576px) 100vw, 576px" /><figcaption id="caption-attachment-7471" class="wp-caption-text">Jim Morrison performing on stage.</figcaption></figure><h3>What did he do after his career breakthrough?</h3><p>The singer died in 1971 in Paris, where he was staying in an apartment. He was found in a bathtub and the cause of death that was given as heart failure, but an autopsy was never performed. His death was said to be linked to heroin use.</p><h2>Jim Morrison’s net worth</h2><h3>What was his net worth?</h3><p>The singer had an estimated net worth of $400 thousand dollars at the time of his death, which is about $2.4 million in today’s dollars.</p><h2>Jim Morrison’s personal life</h2><h3>Who did he date?</h3><p>The singer was known for having many relationships and sexual encounters during his life. He was known for being in an open relationship with Pamela Courson whom he attended college with. Courson was supportive of Morrison’s poetry and performances and was buried with the name Pamela Susan Morrison upon her death, despite the couple never marrying. Courson was named as Morrison’s sole heir at the time of his death. One of his earliest relationships was Mary Werbelow, whom he met as a teenager in 1962. He had a number of encounters with fans and groupies during his career and encounters with other musicians including Janis Joplin. The singer participated in a handfasting ceremony with Patricia Kennealy in 1970 but was said to have turned cold when Kennealy fell pregnant.</p><p>&nbsp;</p><div class='heateorFfcpClear'></div><div style='width:100%;text-align:left;' class='heateor_ffcp_facebook_comments'><h4 class='heateor_ffcp_facebook_comments_title' style='padding:10px;font-family:Arial,Helvetica Neue,Helvetica,sans-serif;' >What do you think about it?</h4><script type="text/javascript">!function(e,n,t){var o,c=e.getElementsByTagName(n)[0];e.getElementById(t)||(o=e.createElement(n),o.id=t,o.src="//connect.facebook.net/en_AU/sdk.js#xfbml=1&version=v7.0",c.parentNode.insertBefore(o,c))}(document,"script","facebook-jssdk");</script><div class="fb-comments" data-href="https://chilloutradio.com/jim-morrison/" data-colorscheme="light" data-numposts="" data-width="100%" data-order-by="social" ></div><script type="text/javascript">jQuery(window).load(function(){null!=heateorFfcpGetCookie("heateorFfcpOptin")&&jQuery("input.heateor_ffcp_fb_comments_optin").prop("checked",!0),jQuery("input.heateor_ffcp_fb_comments_optin").click(function(){if(jQuery(this).is(":checked")){if(heateorFfcpOptin=1,null==heateorFfcpGetCookie("heateorFfcpOptin")){var e=new Date;e.setTime(e.getTime()+31536e6),document.cookie="heateorFfcpOptin=1; expires="+e.toUTCString()+"; path=/"}}else heateorFfcpOptin=0,document.cookie="heateorFfcpOptin=; expires=Fri, 02 Jan 1970 00:00:00 UTC; path=/"});});</script></div><div class='heateorFfcpClear'></div></div><footer class="entry-meta"> <span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://chilloutradio.com/music-artists/" rel="category tag" data-wpel-link="internal">Artists</a></span><nav id="nav-below" class="post-navigation"> <span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="prev" title="Previous"><a href="https://chilloutradio.com/foo-fighters/" rel="prev" data-wpel-link="internal">Everything you need to know about Foo Fighters</a></span></div></nav></footer></div></article></main></div><div id="right-sidebar" itemtype="https://schema.org/WPSideBar" itemscope="itemscope" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar"><div class="inside-right-sidebar"><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://chilloutradio.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"> </label> <input type="submit" class="search-submit" value="Search"></form></aside><aside id="recent-posts-2" class="widget inner-padding widget_recent_entries"><h2 class="widget-title">Latest:</h2><ul><li> <a href="https://chilloutradio.com/jim-morrison/" aria-current="page" data-wpel-link="internal">Everything you need to know about Jim Morrison</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/foo-fighters/" data-wpel-link="internal">Everything you need to know about Foo Fighters</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/tones-and-i/" data-wpel-link="internal">Everything you need to know about Tones and I</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/tina-turners-best-songs/" data-wpel-link="internal">Tina Turner’s Best Songs</a> <span class="post-date"></span></li><li> <a href="https://chilloutradio.com/boy-george/" data-wpel-link="internal">Everything you need to know about Boy George</a> <span class="post-date"></span></li></ul></aside><aside id="custom_html-2" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-3672890885738962"
 data-ad-slot="1198298697"
 data-ad-format="auto"
 data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="categories-2" class="widget inner-padding widget_categories"><h2 class="widget-title">Read by categories:</h2><ul><li class="cat-item cat-item-146"><a href="https://chilloutradio.com/actors/" data-wpel-link="internal">Actors</a></li><li class="cat-item cat-item-147"><a href="https://chilloutradio.com/music-artists/" data-wpel-link="internal">Artists</a></li><li class="cat-item cat-item-152"><a href="https://chilloutradio.com/best-song/" data-wpel-link="internal">Best Song</a></li><li class="cat-item cat-item-98"><a href="https://chilloutradio.com/celebrity/" data-wpel-link="internal">Celebrity</a></li><li class="cat-item cat-item-3"><a href="https://chilloutradio.com/entertainment/" data-wpel-link="internal">Entertainment</a></li><li class="cat-item cat-item-151"><a href="https://chilloutradio.com/fun/" data-wpel-link="internal">Fun</a></li><li class="cat-item cat-item-150"><a href="https://chilloutradio.com/interviews/" data-wpel-link="internal">Interviews</a></li><li class="cat-item cat-item-4"><a href="https://chilloutradio.com/living/" data-wpel-link="internal">Living</a></li><li class="cat-item cat-item-1"><a href="https://chilloutradio.com/people/" data-wpel-link="internal">People</a></li><li class="cat-item cat-item-149"><a href="https://chilloutradio.com/reviews/" data-wpel-link="internal">Reviews</a></li><li class="cat-item cat-item-2"><a href="https://chilloutradio.com/style/" data-wpel-link="internal">Style</a></li></ul></aside><aside id="text-7" class="widget inner-padding widget_text"><h2 class="widget-title">Newsletter:</h2><div class="textwidget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-6325 mc4wp-form-theme mc4wp-form-theme-blue" method="post" data-id="6325" data-name="Chill" ><div class="mc4wp-form-fields"><p> <label>Your name:</label> <input type="text" name="FNAME"></p><p> <label>Email address: <input type="email" name="EMAIL" placeholder="Your email address" required /> </label></p><p> <input type="submit" value="Sign up" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1596823344" /><input type="hidden" name="_mc4wp_form_id" value="6325" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div></aside></div></div></div></div><div class="site-footer  "><div id="footer-widgets" class="site footer-widgets"><div class="footer-widgets-container grid-container grid-parent"><div class="inside-footer-widgets"><div class="footer-widget-1 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-5" class="widget inner-padding widget_text"><h2 class="widget-title">Listing Online</h2><div class="textwidget"><p><a href="https://apps.apple.com/app/chillout-radio/id1492096666" target="_blank" rel="noopener noreferrer nofollow" data-wpel-link="external"><img class="alignnone wp-image-4352 size-full" src="https://chilloutradio.com/wp-content/uploads/2019/12/apple.png" alt="download apple chillout music radio" width="180" height="68" /></a><br /> <a href="https://play.google.com/store/apps/details?id=com.radio.m969ab7845" data-wpel-link="external" target="_blank" rel="nofollow"><img class="alignleft size-full wp-image-4353" src="https://chilloutradio.com/wp-content/uploads/2019/12/android.png" alt="listing to chillout radio station on android" width="180" height="68" /></a></p></div></aside></div><div class="footer-widget-2 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-4" class="widget inner-padding widget_text"><h2 class="widget-title">Contact</h2><div class="textwidget"><p>Get in touch with us by submitting the contact form <a href="https://chilloutradio.com/contact/" data-wpel-link="internal">here</a>.</p></div></aside></div><div class="footer-widget-3 grid-parent grid-33 tablet-grid-50 mobile-grid-100"><aside id="text-3" class="widget inner-padding widget_text"><h2 class="widget-title">Legal</h2><div class="textwidget"><ul><li><a href="https://chilloutradio.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li><li><a href="https://chilloutradio.com/terms-of-use/" data-wpel-link="internal">Terms Of Use</a></li><li><a href="https://chilloutradio.com/feedback-and-complaints/" data-wpel-link="internal">Feedback and Complaints</a></li></ul></div></aside></div></div></div></div><footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope="itemscope"><div class="inside-site-info grid-container grid-parent"><div class="copyright-bar"> <span class="copyright">&copy; 2020 Chillout Radio</span></div></div></footer></div> <a title="Scroll back to top" rel="nofollow" href="#" class="lalita-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300"> <span class="screen-reader-text">Scroll back to top</span> </a><div class="lalita-side-left-cover"></div><div class="lalita-side-right-cover"></div></div> <script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><script type='text/javascript'>var adsforwp_obj = {"ajax_url":"https:\/\/chilloutradio.com\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"ae18da093a"};</script> <script type='text/javascript'>var adsforwp_browser_obj = [];</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/chilloutradio.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script type='text/javascript'>var wpcf7_redirect_forms = {"3856":{"page_id":"4384","external_url":"","use_external_url":"","open_in_new_tab":"","http_build_query":"","http_build_query_selectively":"","http_build_query_selectively_fields":"","delay_redirect":"0","after_sent_script":"","thankyou_page_url":"https:\/\/chilloutradio.com\/thank-you\/"}};</script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lcm7bEZAAAAAMxEmHKhoBfZglBaLmKD-hLTwXN_&#038;ver=3.0'></script> <script type='text/javascript'>var wpcf7_recaptcha = {"sitekey":"6Lcm7bEZAAAAAMxEmHKhoBfZglBaLmKD-hLTwXN_","actions":{"homepage":"homepage","contactform":"contactform"}};</script> <!--[if lte IE 11]> <script type='text/javascript' src='https://chilloutradio.com/wp-content/themes/lalita/js/classList.min.js?ver=1.1.1'></script> <![endif]--> <script defer src="https://chilloutradio.com/wp-content/cache/autoptimize/js/autoptimize_fc86a24f3fc0a8d7351b0e657859a1ee.js"></script></body></html>
<!-- Page generated by LiteSpeed Cache 3.2.4 on 2020-08-08 04:02:24 -->